We are pleased to inform you that the recent service disruption has been resolved. Technicians identified and corrected an inefficient process related to our database services that was causing the disruption.
We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding while we corrected the issue.
Posted Jun 01, 2025 - 11:59 EDT
Update
my Social Security online services may currently be unavailable. We sincerely apologize for the disruption in service you are currently experiencing. We understand how important this is to you, and we are actively investigating the issue to resolve it as quickly as possible.
Posted Jun 01, 2025 - 10:51 EDT
Investigating
We sincerely apologize for the disruption in service you are currently experiencing. We understand how important this is to you, and we are actively investigating the issue to resolve it as quickly as possible.
Your patience and understanding during this time are greatly appreciated.
Posted Jun 01, 2025 - 09:03 EDT
This incident affected: my Social Security Webapp Health.